読者です 読者をやめる 読者になる 読者になる

tmux1.8

tmux

tmux1.8をソースからインストール

libeventが必要なので、先にインストール

libevent-2.0.21

libevent

$ wget https://github.com/downloads/libevent/libevent/libevent-2.0.21-stable.tar.gz
$ tar zxvf libevent-2.0.21-stable.tar.gz
$ cd libevent-2.0.21-stable
$ ./configure && make
$ make verify
$ sudo make install

# echo /usr/local/lib >> /etc/ld.so.conf.d/usrlocal.conf
# ldconfig
# ldconfig -p | grep libevent
tmux1.8

http://tmux.sourceforge.net/

$ tar zxvf tmux-1.8.tar.gz
$ cd tmux-1.8
$ ./configure && make


"curses not found"となるので、以下をインストール

$ sudo yum install ncurses-devel


ncurses-develのインストールが完了したら、tmux1.8を再度。

$ ./configure && make
$ sudo make install